[CentOS] Problem copying files to flash drive

Mon Aug 18 20:10:38 UTC 2008
NiftyClusters Mitch <niftycluster at niftyegg.com>

On Mon, Aug 18, 2008 at 12:41 PM, MHR <mhullrich at gmail.com> wrote:
> I had an interesting experience this weekend backing up some flash
> drives to another flash drive on my CentOS 5.2 home desktop.
> My son had two 256MB flash drives and one 1GB flash drive that he
> wanted backed up onto his newer 2GB flash drive.  I used rsync to copy
> the two smaller ones to the big one without any trouble, but when I
> tried to backup the 1GB files to the 2GB drive, I started getting
> massive "no space on disk" errors.
> After doing this several times, I copied to files to a directory on my
> hard drive and then tried to copy the files again from there to the
> 2GB flash drive (removing all files on the flash drive in between each
> iteration).  Same problem.
> Then I did a cp -R of the directory itself from my hard drive to the
> flash drive, and voila!  All files copied, no problems, except that
> now the files are in a new directory of the same name on the flash
> drive.
> The total number of files in the base directory is 171, and the total
> size of the files copied was a little over 500MB, so I believe that
> everything should have fit just fine.  The commands I used that failed
> were 'rsync -av /media/<drive_name>/ /media/<2GB_drive_name>/' (which
> worked for the two smaller drives but not the bigger one), and then
> (after using the same command to copy the files to my hard drive),
> 'rsync -av ./ /media/<2GB_drive_name>/'
> The command that worked was 'cp -R . /media/<2GB_drive_name>/'
> The only thing that comes to mind is that there were a lot of files
> with ._xxx names on the 1GB flash drive, so I'm wondering if they just
> overloaded the capacity of the flash drive's FAT32 root directory name
> space, but I thought that limit was 512 entries, not less than 171.
> Any ideas?
> Thanks.
> mhr

Sparse files??
See the -S or --sparse flag

 T o m M i t c h e l l