[CentOS] Yum corrupting RPMs

Mon Aug 25 01:35:50 UTC 2008
Stephen John Smoogen <smooge at gmail.com>

On Sun, Aug 24, 2008 at 7:24 PM, Tom Lanyon <tom at netspot.com.au> wrote:
> Hi list,
> Trying to upgrade someone's workstation here to 5.2 (was installed from a
> 5.0 DVD I think).
> The RPMs on our internal mirror are in-tact and pass a 'rpm --checksig'
> test, yet when I run a 'yum upgrade' a large portion of them are corrupted
> and fail the GPG check.
> This seems to be isolated to yum, as downloading the RPM directly via FTP
> with wget or lftpget provides an RPM that *does* pass the GPG check.
> I have upgraded key packages to the latest version (eg. yum upgrade 'yum*')
> and tried again to no avail.
> Anyone seen this before?

The only time I have seen it is where there is a bad HTTP proxy in
between you and the server. It caches a bad rpm and then keeps it til
hell freezes over.

Stephen J Smoogen. -- BSD/GNU/Linux
How far that little candle throws his beams! So shines a good deed
in a naughty world. = Shakespeare. "The Merchant of Venice"