[CentOS] GRUB Timeout problem

Mark Snyder mark at jmktdis.com
Fri Dec 5 17:02:22 UTC 2008

Lanny Marcus wrote:
> On Wed, Dec 3, 2008 at 4:44 PM, Mark Snyder <mark at jmktdis.com> wrote:
>> I recently installed CentOS 5.1 on a DL71 ASI notebook.
>> After my yum update the timeout parameter in /boot/grub/grub.conf file
>> has no effect.  It sits at the grub screen forever unless I press the
>> enter key to select a kernel, at which point it will boot.
>> Any help or suggestions to fix this would be much appreciated
> <snip>
> Have you tried to reinstall GRUB? If you do, possibly the problem will go away.
> <http://wiki.centos.org/TipsAndTricks/ReinstallGRUB>
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
I did the grub reinstall, it did not change anything but thanks for the 
suggestion and link.

I do not know, but I suspect that the problem has something to do with 
the fact that /boot is type ext2 while the rest of the file system is 
type ext3.  I must have done this accidentally installing the system.  
It would take up to much of my time to reinstall the whole system again 
on the laptop, setup repositories, install wine, install wireless, 
install gstm and configure etc etc.

[root at dhcppc3 ~]# mount -l
/dev/hda3 on / type ext3 (rw) [/]
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/hda1 on /boot type ext2 (rw) [/boot]
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)

I also tried umount on /boot and checked to try and find another 
grub.conf file. After the umount command the /boot mount point was empty 
so I do not think this is a problem

Thanks for the suggestions so far, but so far nothing has helped.


More information about the CentOS mailing list