[CentOS] [OT] Firefox loses plugins, anyone else? Bug? Known?

William L. Maltby CentOS4Bill at triad.rr.com
Sat Dec 6 19:58:49 UTC 2008

On Sat, 2008-12-06 at 14:16 +0100, Matej Cepl wrote:
> On 2008-12-05, 23:48 GMT, William L. Maltby wrote:
> >> I was able to _start_ a comparison process, not completed yet. 
> What is the output of the command
> mozilla-plugin-config -l

# mozilla-plugin-config -l
-bash: mozilla-plugin-config: command not found

Hmm... after an updatedb, did this

# locate mozilla-plug

No results.

> ? And if you have flash-plugin in ~/.mozilla then many bad things 

Looks like I'm OK there.

$ cd .mozilla;find . -iname '*plug*'

# locate flash-plugin

This is the one from the adobe site.

# rpm -qv flash-plugin

> will happen to you. Remove it and install the one from Adobe yum 
> repo together with nspluginwrapper from CentOS repos.

Did it.

# rpm -q nspluginwrapper

However, when I restart FF, this plugin does _not_ appear in the
tools->add-ons plugins tab window. Should it? The pluginreg.dat seems to
have been updated and the nspluginwrapper is in there.

]$ cd .mozilla
[hardtolove at centos501 .mozilla]$ find . -iname '*plug*' -ls
16285943   12 -rw-------   1 hardtolove hardtolove     5267 Nov 20
19:55 ./firefox/9be8vroz.default/pluginreg.dat-
16288526    8 -rw-------   1 hardtolove hardtolove       65 Dec  5
17:37 ./firefox/9be8vroz.default/pluginreg.dat-2
16288502   12 -rw-------   1 hardtolove hardtolove     5859 Dec  6
14:32 ./firefox/9be8vroz.default/pluginreg.dat
[hardtolove at centos501 .mozilla]$ date
Sat Dec  6 14:44:38 EST 2008

$ grep nsplug ./firefox/9be8vroz.default/pluginreg.dat
href="http://gwenole.beauchesne.info/projects/nspluginwrapper/">nspluginwrapper</a>  is a cross-platform NPAPI plugin viewer, in particular for linux/i386 plugins.<br>This is <b>beta</b> software available under the terms of the GNU General Public License.<br>:$

> Does it help?

Might be hard to tell since the behavior is inconsistent. But everything
is now set the way "we" think it should be.

> Matěj

Since missing stuff reappeared during testing, I guess there will be a
delay while I see if the behavior occurs again.

I'll keep this post and post either when it happens again or after a few
days if it doesn't happen again.

> <snip sig stuff>

Thanks for all the help,


More information about the CentOS mailing list