[CentOS] suspend/resume system crash

Tosh toshlinux at gmail.com
Wed Dec 17 23:25:34 UTC 2008

Sergej kandyla wrote:
> Max Hetrick wrote:
>> Sergej Kandyla wrote:
>>> I've installed CentOS 5.2 i386 (with all updates) on notebook Fujutsu
>>> Siemens Esprimo  U9200
>>> Suspending works normal, but after resuming my system crashes.
>>> There are  no messages about that in /var/log/messages, only after
>>> reboot system I see in gnome:
>> I have a ThinkPad, but I've never been able to get suspend/resume to
>> work right with CentOS. Hibernation, however, worked fine for me until I
>> started using disk encryption. Now, it too bombs because it can't wake
>> up my encrypted file systems.
>> Have you tried seeing if hibernation works? I know it's not the same,
>> but I know I've never had a laptop that suspend/resume worked when using
>> CentOS.
> Thanks for reply!
> Yes,  hibernation (sleep mode) works fine...
> I'm confused... Not only my freebsd can't work with all hardware :)
> ( Off course I understand that CentOS is server oriented linux, but I
> want use on desktop such  system that I'm using  on my servers. )
> Also I've tried  update gnome-power-manager-2.16.0-9.el5  to
> gnome-power-manager-2.18.2-4.fc7.i386.rpm
> but this didn't take a results.
please try one of the two following commands for sleep :
(1) echo "mem" > /sys/power/state
(2) /usr/sbin/pm-suspend
or for hibernation
(1) echo "disk" > /sys/power/state
(2) /usr/sbin/pm-hibernate

More information about the CentOS mailing list