[CentOS] cpuspeed problems with 5.2 and 2.6.18-92.1.18 kernel revision

ArcosCom Linux User linux at arcoscom.com
Thu Dec 18 07:06:38 UTC 2008

El Jue, 18 de Diciembre de 2008, 1:45, MHR escribió:
> On Wed, Dec 17, 2008 at 4:09 PM, ArcosCom Linux User <linux at arcoscom.com>
> wrote:
>> The same as before, instead compile I do the dd comand and see the
>> /proc/cpuinfo info at the same time the cpuspeed monitor under gnome
>> shows
>> the same as cpuinfo: 800Mhz.
>> Another way to go?
> Can you NOT top post here??

Sorry for my poor english: What is the meaning of "top post"? (spanish
speaker here).

> Let me try again:
> While the dd command is running, what is the content of /proc/cpuinfo?

Please, don't think that I don't know how to run the commands and the
info. To do that I opened 2 gnome-terminal windows and while the dd
command was running I run the "cat /proc/cpuinfo" in the other window and
see the "cpu MHz" value to write here.

But, to allow you to convince, here is it (and more interesting values):
# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.73GHz
stepping        : 8
cpu MHz         : 800.000
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca
cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx up est tm2
bogomips        : 1597.32

# cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq

# cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq

# cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq

# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
1733000 1333000 1067000 800000

# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver

# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
userspace performance

(when I configure "ondemand" in /etc/sysconfig/cpuspeed, above appears
"ondemand" governor too, but the problem persists).

# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq

# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq

(and I think this last value is the problem because I can't change it with
echo "1733000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq)

And while the dd command were running I tried to put performance governor
too into scaling_governor.

I have to insist again, I think that is something that I have
misconfigured or is not working fine in gnome that do something and breaks
the cpuspeed daemon or have any type of incompatibility with it, because,
as I can remember, the cpuspeed were working fine.

I'll try the new 2.6-92.1.22 kernel too, but in the new kernel changelog
not appears to be any type of fix that affect to this.

> Thank you.


> mhr
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

More information about the CentOS mailing list