[CentOS] Unable to connect to printer; will retry in 30 seconds...: Connection timed out

MHR mhullrich at gmail.com
Thu Dec 18 17:24:43 UTC 2008

On Wed, Dec 17, 2008 at 11:42 PM, Indunil Jayasooriya
<indunil75 at gmail.com> wrote:
> Hi ALL,
> When we check logs , we see something like this.
> [Job 888] Unable to connect to printer; will retry in 30 seconds...:
> Connection timed out
> Then, What we do is , We go to application, system setting, printing
> and when we get the window, We click apply button,
> Then, again, We will be able to print.
> Could u pls let me know why?

I can't tell you why, but I can expound on this a little.

I run CentOS on my desktop at home, x86_64.  I started on 4.4 and am
now running 5.2.  During most of this time, I had a Minolta PagePro
1100 printer with parallel (lp0) interface that worked fine - except
that every once in a great while, I would get this error, and there
was NO way to clear it except to reboot.

ABout a month ago, that printer gave up the ghost (ok, the second drum
wore out), so I replaced it with a Brother HL-2140 with a USB
interface.  I noticed that this problem occurs every time I boot my
vmware Windows VM if the printer is attached to the VM, and once,
recently, even when it wasn't.  (I wonder if this is related to the
previous issue on the Minolta....)  What usually clears this is to
empty the queue, go into the System->Administration->Printer applet
(or run system-config-printer as root), disable the printer, cycle
power on the printer, then re-enable it,  Then it works fine.

Interesting points:

1) Only seems to happen when vmware is involved, most often if the
printer is accessible to the vmware VM (usually I have this disabled,
for obvious reasons).

2) Disconnecting the USB cable and plugging it back in has no effect -
I have to cycle the power on the printer, and only after it has been

3) This whole process MUST take at least 30 seconds because if I do it
too fast, it doesn't work.  This may be related to the timeout issue.

I strongly suspect that there is a bug somewhere in the printer system
(CUPS maybe?) such that, once a printer gets out of sync (like this),
it requires a reset to fix it.  With the parallel printer, I had to
reset the system.  With the USB printer, I can reset the printer,
probably because the underlying OS layers are designed to handle USB
devices going on and off line more easily that the parallel device(s).

Given the issue I have seen with vmware, I wonder if the issue in your
situation has to do with passing control of the printer around on your
network.  I know that sort of thing _should_ not happen, but reality
has a nasty way of intruding on our needs-and-expectations-based

Perhaps someone better informed on the details inside can comment....



More information about the CentOS mailing list