[CentOS] flash fails to work on Los Angeles Times website - fix

Mark Pryor tlviewer at yahoo.com
Sun Dec 21 03:13:03 UTC 2008


I have a 32-bit install of C5.2 on my Intel Centrino Laptop (2005).
The Adobe flash plugin works fine in Firefox in all cases except on the Los Angeles Times website http://www.latimes.com.

I was baffled by this for a few months, since it works on another 32-bit C5.2 box. When I realized that the only real difference was that the laptop had no LAMP install, and both had the same elaborate set of hosts redirects (to avoid adverts), it seemed reasonable that the /etc/hosts file might be the culprit.

Sure enough, both boxes had this line in the redirects
----------- /etc/hosts ------------ ad.doubleclick.net
----------- end snip ---------

I could see that flash was hanging on the laptop when it looked for a response from ad.doubleclick.net

In order to fix the bug, I commented out the line. Flash now worked!
In order to avoid the advert, I changed, to another private LAMP install on my home network ( Problem solved.

At the very least this redirect needs to return a response, or the flash video will hang and never start. This is true for the LA Times implementation of adverts, at least. Maybe your newspaper sites behave similarly.

My 2cents worth of troubleshooting,


More information about the CentOS mailing list