[CentOS] Rebuild xorg (continued from Centos-devel)

William L. Maltby CentOS4Bill at triad.rr.com
Sun Dec 21 22:38:39 UTC 2008

On Sun, 2008-12-21 at 22:48 +0100, Alain PORTAL wrote:
> Le dimanche 21 décembre 2008, William L. Maltby a écrit :
> > If you get to single-user with a boot (adding the " 1" in grub edit
> > mode), alternate consoles will have some stuff of possible value.
> > <CTRL>-<ALT>-<Fx> (where the Fx is function key F1, F2, F3, ...) should
> > switch you to other screens. Also, <ALT>-<RIGHT> or <ALT>-<LEFT> can be
> > used to cycle through. If X has not been started, the <CTRL> can be
> > omitted from that first set I mentioned.
> If I start up in single user mode, I get only one console. No switch possible.
> So I start in run-level 3.

I forgot about that. Run level 3 is good too.

> > Once you are at the root prompt, do the system-config-display with no
> > parameters. Looking at the alternate consoles while the config is
> > running might be helpful.
> If I run system-config-display in, saying tty1, it start successfully.
> If I switch to tty2, then back to tty1, I don't see the system-config-display 
> dialog any more, just the command I typed before.

Drat! Yes, running in text mode, the screen buffer gets lost when you switch
virtual terminals. So many things I've forgotten over time.

> > If the system finds _any_ driver it can use - e.g. vga, svga, vesa - it
> > should bring up a graphical screen that has a computer icon and some
> > tabs for display, multi-head, etc. There's a couple drop-down menus that
> > let you select resolution, color depth, etc.
> Unfortunately, resolution is too low (320x200), so, I can't see the "Cancel" 
> and "Valid" or "OK" button of the system-config-display dialog.

Try again with the resolution parameters like Alan suggested but with
lower resolution and "vga", e.g.

   system-config-display --set-resolution=640x480 --set-driver=vga

Note that I changed "vesa" to "vga" since the card mentions only vga.

I don't know if that will work because I see the "insufficient memory"
message you mention below. That may be a result of color depth combined
with memory limitations. But if it does work, maybe you get going good
enough to proceed.

BIOS! That memory thing reminds me. See below.

> > Select something not too "heavy" and save the settings and exit.
> >
> > If only part of the screen is visible, maybe the screen is scrollable?
> Unfortunately not.
> > Try moving the mouse off the edge (Hmm. Is the mouse working during this
> > process? I forgot to test that).
> Mouse is working.
> > 1) Can you get/see what I described at all?
> > 2) If you can, and if you make and save changes, you should be able to
> > get to a graphical screen later. BUT FIRST ...
> > 3) At a root prompt, type dmesg | less and look for any messages that
> > might give clues. This might be useful regardless of the results of 2).
> >
> > Also, there might be useful messages in /var/log/messages
> > and /var/log/Xorg.*.
> I don't know if I can post such heavy files here...
> This is a devel list, not a user one.
> Xorg.0.log is 38Kb and messages is 435Kb !

Not the whole file, just save some of the pertinent lines in a file
and copy them into the reply. But maybe this won't be needed. See below
about possible BIOS.

> > I don't recall what card you have - nvidia?
> VGA compatible controller: ATI Technologies Inc M71 [Mobility Radeon X2100] 
> (rev ce) (prog-if 00 [VGA controller])

Well, then you should be able to get any vga or svga compatible mode
going. (S)VGA is a well-defined set of standards that if a card says
it is compatible, the interface is "standard" and the card says it
can support those compatible modes.

Since the text mode changes worked with the "vga=" added, there may be some
hope yet.

> I think now it's a X server problem as it can't compute modelines for vga 
> module. I get, in Xorg.0.log, many lines as:
> (II) VGA(0): Not using default mode "320x240" (insufficient memory for mode)
> Lines differs in mode value
> (II) VGA(0): Not using default mode "1920x1200" (insufficient memory for mode)
> I know that the 1920x1200 mode is doable.

Have you gone into BIOS and seen what is there that might be affecting
this stuff? I know there are often selectable modes for video cards.
Often in a laptop, main memory is shared with the video card. If you
have not allocated enough memory to the video, maybe that is causing
a lot of the problems? If you "system" memory is really small, you may
not be able to get decent resolution with higher color resolutions.

If your BIOS has settings, start off with 4 bit color depth. That gives
16 colors only, but it's a start. Also pick a low resolution, like
640x480 or 800x640(?).

Maybe a combination of 4 bit color depth, low resolution, more memory
shared with video chip, etc. makes it start working. Oh! Don't forget
the video card mode if the BIOS has a setting for it.

> Regards
> Alain
> <snip>

We're starting to get close to the end of things I can think of. I hope
something works here!


More information about the CentOS mailing list