[CentOS] following Centos wiki headless install, but applying to FC10

Mon Dec 1 18:10:32 UTC 2008
Robert Moskowitz <rgm at htt-consult.com>

I have successfully built an install CD following the instructions at:


Now I am trying to do the same with FC10 and I am failing in two ways.  
I have tried to find a similar howto for even FC9, but have not found 
the right google magic.

The first problem should be small.  When I set isolinux.cfg to start with:

prompt 1
timeout 0

I still get prompted.  There is quite a bit more to the beginning of the 
FC10's isolinux.cfg so that might account for it.  But fortunately I do 
have a keyboard of sorts and a monitor of sorts so I can get to my menu 
select for remote vnc install.  The install then proceeds and gets to 
setting up eth0, but fails.  It seems like dhcp is not succeeding.  If I 
boot from the standard FC10 CD, hdcp does work.  Here is my append line:

 append initrd=initrd.img vnc vncconnect= headless ip=dhcp 
ksdevice=eth0 meth
od=http://server.foo.com/fedora/10/os/i386 lang=en_US keymap=us

All these commands are listed at:


Any pointers to where to get help on this?