[CentOS] GRUB Timeout problem

Fri Dec 5 19:20:45 UTC 2008
Mark Snyder <mark at jmktdis.com>

MHR wrote:
> On Fri, Dec 5, 2008 at 10:44 AM, Nicolas Thierry-Mieg
> <Nicolas.Thierry-Mieg at imag.fr> wrote:
>> Mark Snyder wrote:
>>> I do not know, but I suspect that the problem has something to do with
>>> the fact that /boot is type ext2 while the rest of the file system is
>>> type ext3.  I must have done this accidentally installing the system.
>>> It would take up to much of my time to reinstall the whole system again
>>> on the laptop, setup repositories, install wine, install wireless,
>>> install gstm and configure etc etc.
>> I doubt this is the source of your problem, but google can tell you how
>> to convert an ext2 fs to ext3 (tune2fs). Very easy, nothing to reinstall.
> I agree.
> Are you sure that the hardware is supported on CentOS?  I don't
> recognize the specific model you mentioned, so I don't know what CPU,
> motherboard, memory, etc. you have.
> Have you tried timeout=0?
> Have you checked all the PROM settings?
> I'm just fishing here 'cuz nothing so far rings a bell....
> mhr
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
You are both absolutely correct, changing from ext2 to ext3 did nothing 
to fix this.  Not sure about the MB manufactured but it is a Pentium M 
1.60GHz stepping 08 CPU with an Intel 915G chipset and a WD600UE ATA HDD

About the only options in the BIOS are the Date and Time and the Boot 

I had actually tried to load Ubuntu first as I had herd (pun intended) 
"good things" about it. Was not at all happy with that distro and moved 
back to CentOS ASAP.

Setting timeout=0 does allow it to boot without having to press the 
enter key.  The splash screen just flashes then the boot starts.
Not really a solution but a workaround.  I can live with it this way but 
still curious as to what is going on.