[CentOS] INIT 5 and system is gone

John jses27 at gmail.com
Wed Jul 2 14:22:34 UTC 2008

 ---Original Message-----
From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On Behalf
Of Robert Moskowitz
Sent: Monday, June 30, 2008 11:49 AM
To: CentOS mailing list
Subject: Re: [CentOS] INIT 5 and system is gone

Michel van Deventer wrote:
> Hi,
> On Mon, 2008-06-30 at 10:33 -0400, Robert Moskowitz wrote:
>> I had been running a system on Centos 5.1 at INIT 3.  I did the 
>> upgrade to Centos 5.2 with the aid of the powernowk8 patch.
>> Previously I would VNC into the unit when I needed to do admin stuff 
>> with a GUI.  Well I noticed that I was NOT getting GNOME via VNC 
>> since the upgrade (worked before just fine with 5.1).  So I tried an 
>> INIT 5 from the command line (always worked before), but the system 
>> seemed to hang.  Video was off.
>> I rebooted, went to INITTAB and changed init to 5 and rebooted.  
>> Probably a tragic mistake.
>> Now on boot, right after UDEV gets an OK, the screen goes blank and 
>> the drive stops turning.
>> I tried booting with the 5.1 kernel, and same behaviour with the 
>> system blanking out and all load activity stopping after UDEV loads.
>> So I am quite stuck at this point.
>> Is there an option that I can edit into the kernel command at boot 
>> time to init in 3?  And then what do I try?
> Reboot your system, when you see the grub menu, press a key. Select 
> the kernel you wish to boot and press 'e', select the kernel line, press
> again and add '3' at the end of the line (or '1' if you wish to boot 
> in single user mode). Then press <enter> and 'b' to boot. Your system 
> should now boot up in level 3. You can log in as root at the login 
> prompt. If that even doesn't work, the reboot in single user mode.
Thanks that got me back in.
> For the rest, we first need
> logfiles, /var/log/messages /var/log/boot.log
Nothing.  boot.log is completely empty no-one home.

For messages, the boot with init 5 had NO entries.  As if the crash 
occured before the first entry would be written.  And running startx did 
not result in anything in messages either.
> and
> maybe /var/log/Xorg.0.log
Now here we might have something.  There is only one likely entry in 
Xorg.0.log from friday, it seems.  It looks like from the time I tried 
init 5 from the command line:

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.1.14.el5PAE i686 Red Hat, Inc.
Current Operating System: Linux decTOP1.htt-consult.com 
2.6.18-92.1.6.el5.bz_pre53 #1 SMP Thu Jun 26 12:08:44 EDT 2008 i586
Build Date: 21 June 2008
Build ID: xorg-x11-server 1.1.1-48.41.el5_2.1
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 27 14:47:28 2008
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "single head configuration"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Videocard0"
(**) |-->Input Device "Keyboard0"
(==) |-->Input Device "<default pointer>"
(==) The core pointer device wasn't specified explicitly in the layout.
        Using the default mouse configuration.
(==) No FontPath specified.  Using compiled-in default.
(==) FontPath set to:
(==) RgbPath set to "/usr/share/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.3
        X.Org Video Driver: 1.0
        X.Org XInput driver : 0.6
        X.Org Server Extension : 0.3
        X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so

Perhaps I should try this again and see if I get another update in this 
log file....

Anyway, something is really wrong here!  Help, please?
Try changing your Loging Level to "Debug" or use the appropriate number 1-4
for it. Use your backup Xconfig file if you got one. You do have it backed
up correct?


CentOS mailing list
CentOS at centos.org

More information about the CentOS mailing list