[CentOS] Back to my Xwindows kernel panic

Robert Moskowitz rgm at htt-consult.com
Fri Jul 4 17:02:25 UTC 2008

I have a newly built drive with 5.2 fresh install (that I will be 
cloning shortly) in my DECtop and it is failing with X the same way the 
upgrade from 5.1 drive did (not too supprising there).

In 5.1 X worked.  I could startx from init 3 and get into GNOME.  Also 
VNC into the box and have a GNOME screen.  With 5.2, I get a kernel 
panic.  Well I guess it is a kernel panic because once I run startx from 
the console, my SSH session to the box from my notebook is frozen.

 From /etc/sysconfig/hwconf I have:

class: VIDEO
bus: PCI
detached: 0
desc: "National Semiconductor Corporation Geode GX2 Graphics Processor"
vendorId: 100b
deviceId: 0030
subVendorId: 100b
subDeviceId: 0030
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  1
pcifn:  1

the /etc/X11/xorg.conf has

# Xorg configuration created by system-config-display

Section "ServerLayout"
    Identifier     "single head configuration"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "us"

Section "Monitor"
    Identifier   "Monitor0"
    ModelName    "Monitor 1024x768"
 ### Comment all HorizSync and VertSync values to use DDC:
    HorizSync    31.5 - 57.0
    VertRefresh  50.0 - 70.0
    Option        "dpms"

Section "Device"
    Identifier  "Videocard0"
    Driver      "vesa"

Section "Screen"
    Identifier "Screen0"
    Device     "Videocard0"
    Monitor    "Monitor0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Modes    "1024x768" "800x600" "640x480"

Now the way I got this working in 5.1 and 5.2 (5.1 install died for some 
reason or other, forget which and for 5.2 this unit has the powerk8 
patch requirement), I install on an old compaq and change to init 3.  I 
then move the drive and run system-config-display to get the unit to 
read the hwconf file and reset xorg.conf.  This worked fine in 5.1.  In 
5.2, the system hangs.  What to do?  btw, i tried pci=noapci with no change.

A couple other facts about this system.  No accessable bios.  When the 
system is booting (in character mode) the video frequently goes off then 
back on; some refresh problem.  I have also seen this at times in a 
session on the console when I enter some commands.  It would be nice to 
fix this.  It might also tie in with the X problem.

Thank you for your continued help.


More information about the CentOS mailing list