FW: [CentOS] Problem with nvidia-drv-x11 when upgrading to CentOS5.2 (Akemi)

Fabian Arrotin fabian.arrotin at arrfab.net
Sat Jul 5 11:37:24 UTC 2008

John wrote:
> -----Original Message-----
> <snip>
> Akemi, 
> Yes, someone did mention that. The only thing I am kind of worried about
> when just copying it is, the difference between the Kernel Versions. Using
> it over the same generation of kernels I'm assuming it is of the 2.6.x.x.x
> family of kernels? If it works without problems then good. It's that I have
> all ways recompiled a Kernel module to the latest kernel on the machine.
> I also know from previous email and notes that it will not work with the Xen
> Kernel unless something has changed. None the less I've thought about giving
> a wack at it just to try.
> JohnStanley
That's the reason why you like to have the same kernel during the distro 
lifetime: you can take a module from 2.6.18-53 and use it on 
2.6.18-92.1.1 ... of course you have to copy it and use depmod -a (or 
use the weak-updates script that is called after each kernel update)
You're right that nvidia kmod doesn't work with Xen kernels though ...
Fabian Arrotin <fabian.arrotin at arrfab.net>
"Internet network currently down, TCP/IP packets delivered now by 
UPS/Fedex ..."

More information about the CentOS mailing list