[CentOS] i386 version of Perl getting installed on x64 system?

Joseph L. Casale JCasale at activenetwerx.com
Sun Jul 6 16:25:57 UTC 2008

>Just to muddy the waters on this a bit more... for me, the rpmforge
>perl-Time-HiRes package won't install as it conflicts with my base
>installation of perl.

Yea, I just figured that out.

>This is on a RHEL5.2 x86_64 system however.

So I assume an x86 install doesn't have this issue?

># rpm -qf --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n' /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/Time/HiRes.pm
>So it seems HiRes is already provided by perl, although the actual file
>that conflicts is a man page.

Doing a perldoc Time::HiRes gave info, so yes it does look like its provided already.

>(This is why I generally avoid rpmforge if I can :)

What else do you use then? I understood rpmforge was supposed to be the best 3rd part repo
for CentOS? I would assume any repo will have some issues once and a while...


More information about the CentOS mailing list