[CentOS] Re: SIGPIPE in assorted apps after "yum update"

John Hanks griznog at gmail.com
Mon Jul 7 13:07:15 UTC 2008

On Sun, Jul 6, 2008 at 9:23 PM, John Hanks <griznog at gmail.com> wrote:
> On Sun, Jul 6, 2008 at 7:44 PM, John Hanks <griznog at gmail.com> wrote:
>> Hello,
>> I have several systems which I recently updated with
>> yum -y update
>> to all the latest packages. These systems use yum-priorities and use
>> the CentOS (priority 1) EPEL (priority 5) and rpmforge (priority 10)
>> repositories. After the updates, dhcpd stopped working with a SIGPIPE
>> error which occurs shortly after it attempts to fork into the
>> background. I worked around that problem by building a new server with
>> no additional repos, only CentOS and dhcpd works fine on that system.
>> Since then I have found the problem, or similar problems with a few
>> more applications. Here is what the tail of an strace of pbs_mom as it
>> attempts to fork into the background:

Paul Bijnens pointed out that Ian Forde had similar issues with dhcpd
minutes before I posted my message. I missed that one as I scanned the
archives, then joined the list to ask my question. My problem is also
solved by removing ldap from the services line in /etc/nsswitch, in
every app that was previously failing with the SIGPIPE errors. I'm
still curious to understand why, but more so I'm grateful to have a
fix for it. Should have joined the list a long time ago :)



More information about the CentOS mailing list