[CentOS] Difficulties with Seamonkey plugins on 5.2

MHR mhullrich at gmail.com
Thu Jul 17 19:33:58 UTC 2008

Has anyone else noticed this?

I've been running a self-built, working 64-bit version of Seamonkey's
2.01a pre-release (alpha) version for the last six or seven months
(because the "contributed" unofficial 64-bit build didn't work right
and the official 32-bit release crashed all the time), and it's been
working relatively well until recently, particularly in the area of

After updating to CentOS 5.2, I noticed that the flash plugin didn't
work right.  This might be due to a major change in nspluginwrapper -
it is now included in the CentOS (RHEL) release, as opposed to being a
download from rpmforge.

Problem is - it doesn't seem to work right.  My flash plugin does not
work.  At all.

There was a new official release of Seamonkey (1.1.10) with an
available contributed 64-bit build (haven't gotten around to the
1.1.11 revision yet), so I though, maybe this time it will work
better.  I pulled down this revision and installed it.  Works great -
except for the flash plugin.  (Actually, I only know that the acrobat
reader plug-in works, but the flash plugin definitely does _not_.)  I
tried again with 1.1.11 here at work (32-bits) and it seems to work
just fine.

But, as of this morning at least, my home system absolutely does NOT
work with the new nspluginwrapper, and the flash plugin does not work
at all.  This is true both on the 1.1.10 unofficial contributed 64-bit
build, and also my home built 64-bit 2.01pre (with fresh source as of
this morning).

Does anyone have the new ( nspluginwrapper working with the
flash plugin on a 64-bit install of CentOS 5.2 and Seamonkey?

Also, one of the "tricks" I learned with this whole setup was that the
simplest way to "install" the plugins was simply to create symbolic
links from /usr/lib64/mozlilla/plugins - I think that's right - to the
relevant plugins directory.  This worked until 5.2, or at least
Seamonkey reports that the plugins are installed.  (The AR8 plugin has
serious problems, haven't gone all the way back to the AR7.9 plugin
yet, and I haven't tested the mplayerplug-in yet, but the critical one
is the flash plugin because so many web pages have flash videos on
them these days.)

Suggestions welcome.



More information about the CentOS mailing list