[CentOS] harddisc or nfs based install

rado rado at rivers-bend.com
Tue Jul 22 05:28:13 UTC 2008

On Mon, 2008-07-21 at 21:34 -0700, Mark Pryor wrote: 
> --- On Mon, 7/21/08, Joseph L. Casale <JCasale at activenetwerx.com> wrote:
> > From: Joseph L. Casale <JCasale at activenetwerx.com>
> > Subject: [CentOS] harddisc or nfs based install
> > To: "'CentOS mailing list'" <centos at centos.org>
> > Date: Monday, July 21, 2008, 6:57 PM
> > When choosing either of these methods and using an iso, how
> > does CentOS determine
> > the right iso file to mount? Is there an expected file name
> > format?
> Joseph,
> Say you have the iso: CentOS-5.2-x86_64-bin-DVD.iso  (4.6 GB)
> that iso is too big for a vfat partition, so it should be downloaded to
> an ext3 type.
> If you check the images folder (after mounting as iso9660)
> mount -t iso9660 ./CentOS-5.2-x86_64-bin-DVD.iso /mnt/nfs -o loop,ro
> IOW check /mnt/nfs/images
> inside there are several mini-boot images: an boot.iso to burn to CD and 
> diskboot.img for a USB boot.
> Using either, once you get to the prompt:
> >linux askmethod
> it will bring up the menu for nfs or harddisk.
> nfs
> ----
> nfs has worked flawlessly for me. You need another box which has the iso
> mounted (shown above) and that mount point exported via nfs. Make sure the box targetted for install has a common enough ethernet device which the boot kernel supports and plug it in to your network. The installer will configure it for dhcp.
> You will need the IP address of the nfs server and its nfs mount point (/mnt/nfs) to get the installer kicked off.
> harddisk
> -------
> This method has not worked for me on C5, though on fedora it always worked.  To see for yourself, pick a neutral partition (ext3) like /data and put the DVD iso in the root. If the iso is unique and the only possible C5 DVD iso, then all you need to give the menu is the device name (/dev/sda3 or whatever it is) -- the installer will do the smart thing and find the iso.
> It will start to boot and the install will begin, but it will fail early in the same spot -- IIRC, its the proposal/partition stage or immediately there after. I've always given up on the harddisk method on C5. I would be very happy to hear that others got it to work!

I am just wondering if you might be experiencing a problem connected to
the updated script language...some commands changed or deprecated...I
know I went thru some of that at the advent of c5.0...just a thought


More information about the CentOS mailing list