[CentOS] /etc/hosts missing localhost?

Rudi Ahlers Rudi at SoftDux.com
Tue Jul 22 19:26:03 UTC 2008

Bill Campbell wrote:
> On Mon, Jul 21, 2008, Jim Perrin wrote:
>> On Mon, Jul 21, 2008 at 9:20 PM, Bill Campbell <centos at celestial.com> wrote:
>>> Is there any reason why /etc/hosts would be missing the line,
>>> localhost?
>> Nope. It's there by default in some form or another.
>> By default, it usually looks like this ->
>>       installname  localhost.localdomain  localhost
>> ::1          localhost6.localdomain6   localhost6
>> If you don't have anything like this in your /etc/hosts, you either
>> need to find a mirror and begin yelling at responsible parties, or
>> stalk whomever else has root on this particular machine.
> I guess I could yell at myself as I'm doing kickstart installs from
> a local mirror.
> I found the same thing on two CentOS 5.1 installs here, one on a
> VMware VM, the other on real iron.  The wierd thing is that the
> base VMware VM I have that I copy to create new VMs looks OK.
> Now I'm going to have to poke around to see what's causing this
> line to be deleted.
> Bill
I had a similar problem using OpenVZ images, installed from kickstart - 
almost like it's leaving some stuff out by default. So I ended up 
creating the file manually and adding it to the kickstart file to be 
copied over.


Kind Regards
Rudi Ahlers

Check out my technical blog, http://blog.softdux.com for Linux or other technical stuff

More information about the CentOS mailing list