[CentOS] Re: BUG: soft lockup - CPU#1 stuck for 61s!

nate centos at linuxpowered.net
Tue Jul 29 15:15:31 UTC 2008

Johnny Hughes wrote:

> We don't have too many servers (about 20 in 5 locations) or workstations
> (about 150 in 5 locations) but I have had no problem with Dell machines
> or their service ... maybe I am just lucky.

The company I'm at has about 380 dell servers and probably 100 desktops.
For the most part they work fine.

We did have a problem with firmware on Seagate drives that came in
the servers though. The company spent months trying to track down
the source of the problem before I was hired. It didn't take me too
long to narrow it down. The issue was multithreaded reads/writes
to the disk under their application was 10x slower on some systems
than others. Normal disk benchmark tools didn't pick up anything
unusual. And my co-workers said Dell support was worthless for
anything other than flat out RMA (I've never dealt with them so
can't say from personal experience). My experience with HP support
has been similar though, so I don't doubt it.

But I noticed pretty quick after I was hired that the systems that
had problems had Seagate drives, and the ones that did not had Maxtor,
or Fujitsu drives. Unfortunately upgrading the drive firmware was a
painful procedure involving booting to DOS. After updating the
problem was gone, of course.

Why some drives shipped with Maxtor, some with Fujitsu, and some with
Seagate drives I don't know(all the same model#). I've been told
that Dell has a history of swapping out components to whichever is
the cheapest that week, it seems that's the case at least with HDDs.

Never personally had a problem with firmware on a disk in my experience
with thousands of drives over the past 15 years or so. Not sure how
that got past Dell's "QA". Maybe it was a compatibility issue with
their RAID controller and that firmware rev on the disk.

I suppose the main thing I don't like about Dell that I did like
about the HP systems was being able to monitor the RAID array was
pretty simple with HP, we installed a tool called 'hpacucli', no
extra drivers needed, and it worked fine. With Dell the only tool
I've found is 'raidcfg', and that seems to require a bunch of extra
packages and drivers to be installed. And on at least a couple different
types of Dell systems it causes them to hang when I run it. I really
don't like installing "extra" drivers for management stuff. I never
installed the HP management packs, and don't plan to touch the Dell
stuff either(short of raidcfg and it's dependencies).

Dell doesn't seem to be too bad though, I honestly expected more
problems given the pricing of the systems. Some of the pricing
is even cheaper than a local Supermicro reseller, and I'm talking
low quantities even. One of my former employers switched to Dell
after they were bought out by a bigger company(bigger company's
policy) and they pay at least 50% less than we do.

I've only been working with them for a few months now.


More information about the CentOS mailing list