[CentOS] Re: ISC dhcpd and Vista clients

Scott Silva ssilva at sgvwater.com
Thu Jul 31 19:02:14 UTC 2008

on 7-31-2008 10:37 AM James N. Smith spake the following:
> -----Original Message-----
> From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On Behalf
> Of Scott Silva
> Sent: Thursday, July 31, 2008 1:20 PM
> To: centos at centos.org
> Subject: [CentOS] Re: ISC dhcpd and Vista clients
> on 7-31-2008 10:06 AM Glenn spake the following:
>> At 12:52 PM 7/31/2008, you wrote:
>>> on 7-30-2008 11:20 PM Paul Bijnens spake the following:
>>>> Scott Silva wrote:
>>>>> on 7-30-2008 2:53 PM Paul Bijnens spake the following:
>>>>>> Scott Silva wrote:
>>>>>>> Has anyone had good luck serving dhcp addresses to Vista clients 
>>>>>>> that work reliably?
>>>>>>> I have a test system and I can't seem to find out how to properly 
>>>>>>> get dhcpd to always respond with broadcast instead of unicast 
>>>>>>> since Vista won't honor unicast dhcp packets.
>>>>>> My Vista (my wife's actually) has no problems with unicast dhcp 
>>>>>> packets.
>>>>>> Stock dhcpd server in CentOS 5, and Vista Home. Worked without any 
>>>>>> special config.
>>>>>> Are you sure that is the problem?
>>>>> Not sure, but it is one of the suggested problems I see in many 
>>>>> google searches. There are registry edits that help, but I don't 
>>>>> want to have to do a bunch of edits when we get stuck with a hundred 
>>>>> Vista machines. I have plenty of time, for now, to experiment. There 
>>>>> are posts that say the subnet needs to be authoritative, but mine 
>>>>> is. What happens is that the Vista system will not route outside the 
>>>>> local subnet for more than 5 or 10 minutes.
>>>> Do you mean that you do get an IP-number and default gateway from the
>>>> dhcp server, but after 5 to 10 minutes, the default route setting gets
>>>> lost?
>>>> To me that would mean that the dhcp is working fine, but something 
>>>> else kicks in after that time that messes up the dhcp settings.  Any 
>>>> additional firewall software on the laptop, like Norton etc.
>>>> Or can you relate the loss of routing to an action on the dhcp server,
>>>> like lease renewing etc.
>>> I think I am going to have to spend some more time on this. Maybe with 
>>> a sniffer and some patience. The laptop just had Vista Ultimate 
>>> because that is the version we acquired for testing, and our standard 
>>> McAfee virus scanner. I will have to toss together a VM machine and 
>>> try different combos of stuff. As a matter of fact I have a VM loaded 
>>> on my laptop that I was playing with at home as it runs fine there. 
>>> That way the only difference will be the change in  location. It is 
>>> just dog slow, but for this test it doesn't matter that much.
>>> I'll have to look at the troubled machine and see if I can detect 
>>> problems in the routing tables and such. I just have to figure out if 
>>> the same commands do what I want between Vista and XP, or if I need to 
>>> do some reading.
>> My recent reading has lead me to believe that Windows Vista comes with 
>> IPV6 enabled by default and can really generate some traffic if you do 
>> not turn it off and possibly cause problems if your network 
>> infrastructure does not support it. Is that possibly a problem?
>> Cheers,
>> Glenn
>> I turned off IPv6 on that machine, but since it is in our other office, I 
>> won't get back to it until tomorrow to poke it some more.
> I'm not sure if this is related.  I am running a Linksys WRVS4400N router
> (which has Linux based firmware) for my DHCP.  I am noticing that my one
> vista machine is having a difficult time with the DHCP.  I haven't solved it
> yet but what I have seen is that the problem appears to be with the lease
> times and renewal.  When my IP addressing fails on the Vista machine and I
> check the lease table on the router I note that the machine appears on the
> list but has a MUCH shorter lease time remaining than the XP machines.  As I
> take this machine in and out of the house a good bit I run across this
> problem every few days.  Rebooting the router has been my only recourse
> until recently.
> I moved to a new firmware and also maxed out the lease time on the DHCP
> service.  You might want to increase the lease time on your CentOS DHCP
> server and see if it effects the situation. 
> Wish I could be of more help, but I'm just starting to troubleshoot the
> problem.  The one thing I know for sure is that it seems isolated to only
> Vista clients.  I do not know if the Linksys firmware is using the same
> version of ISC DHCPD that CentOS.
> Regards,
> James
Many of the articles point to the fact that Vista, by the will of the 
Microsoft demons, changed how it deals with the broadcast flag in dhcp packets.


This issue occurs because of a difference in design between Windows Vista and 
Microsoft Windows XP Service Pack 2 (SP2). Specifically, in Windows XP SP2, 
the BROADCAST flag in DHCP discovery packets is set to 0 (disabled). In 
Windows Vista, the BROADCAST flag in DHCP discovery packets is not disabled. 
Therefore, some routers and some non-Microsoft DHCP servers cannot process the 
DHCP discovery packets.

Microsofts answer is that Vista is right and the rest of the world is wrong 
(typical), but if you want it to work you have to regedit every affected 
machine and change something.

That is unacceptable in a business environment, IMHO.

The other answer is to get ISC dhcpd to honor the broadcast flag, and 
broadcast all packets instead of unicasting the answer packets. That I can't 
find a setting for.

MailScanner is like deodorant...
You hope everybody uses it, and
you notice quickly if they don't!!!!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 258 bytes
Desc: OpenPGP digital signature
Url : http://lists.centos.org/pipermail/centos/attachments/20080731/bcf0afce/signature.bin

More information about the CentOS mailing list