[CentOS] Re: Network problems on new CentOS 5 install on P35, ICH9R mobo

Tom G. Christensen tgc at statsbiblioteket.dk
Mon Jun 9 09:46:06 UTC 2008

Juan C. Valido wrote:
> On Tue, 2008-06-03 at 23:49 +0100, Ned Slider wrote:
>> Dick Roth wrote:
>>> Juan C. Valido wrote:
>>>> On Tue, 2008-06-03 at 06:09 -0400, Dick Roth wrote:
>>>>> Had to replace dying cpu and mobo, so also replaced IDE with new SATA 
>>>>> drive.  Installed from latest ISO onto SATA and can't get networking 
>>>>> to lease an IP address from my ISP (Comcast).  The network utility 
>>>>> always comes up with a private address ( instead of 
>>>>> Comcast IP.
>>>>> To add to confusion, if I boot into old IDE drive, I get proper 
>>>>> network connection to internet, but lose my swap!
>>>>> Particulars:
>>>>> mobo=Gigabyte P35-DS3R
>>>>> SATA Controller=AHCI
>>>>> PATA Controller=JMicron 20360
>>>>> new drive=ATA WDC WD1600AAJS-2
>>>>> old drive=WDC WD400JB-00JJA0
>>>>> DVD-RW=Pioneer DVR-112D (PATA)
>>>>> NICs=eth0=Realtek RTL-8029(AS) (DHCP)
>>>>>       eth1=Realtek RTL-8029(AS) (Static)
>>>>> Has anyone seen this?  Will 5.2 help with this situation?  Been 
>>>>> working on this for days!
>>>> If it helps any, I tried installing 5,1 on a P35-DS3L and I believe I
>>>> had issues with the network card, loaded RHEL 5.2 desktop and everything
>>>> worked so maybe 5.2 will work for you.
>>> Thanks for the info, Juan.  I'll just hold tight until 5.2 comes down 
>>> the pike.
>>> Dick
>> Release notes list the following Realtek drivers added, but I don't see 
>> yours mentions:
>> http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Release_Notes/x86/ar01s01.html
>> Network driver r8169 updated to add support for the following devices:
>>        RTL8169sb/8110sb
>>        RTL8169sc/8110sc
>>        RTL8168b/8111b
>>        RTL8101e
>>        RTL8100e
> I don't know maybe it's not listed but it's compatible, I know that it
> works. Same thing with OSX86, it works <GRIN>
Updating the r8169 driver will not solve a driver issue with the RTL8029 
The RTL8029 is an old NE2000 clone chip (must be atleast 10 years old by 
now). It was common on cheap 10Mbit PCI cards and is supported by the 
ne2k-pci driver for many years (and the plain ne2k driver before PCI 
support was split out).


More information about the CentOS mailing list