[CentOS] LDAP syncrepl incompatibility between CentOS 4.x and 5.x

Craig White craigwhite at azapple.com
Wed Jun 11 22:24:24 UTC 2008

On Thu, 2008-06-12 at 00:08 +0200, Ralph Angenendt wrote:
> nate wrote:
> > Brett Serkez wrote:
> > 
> > > Has anyone else seen this issue?  Is anyone aware of a fix in the
> > > pipeline or a work around?
> > 
> > Compile the source rpm from centos 5.x on a 4.x system and upgrade the
> > 4.x systems to it ? (short of upgrading the entire OS to 5.x if you
> > don't want to do that it can be a major change depending on your
> > environment)
> I tried to do that, as I wanted to have LDAP overlays (hey, anyone who
> wants to test those on CentOS 5 - there are packages in the testing
> repository).
> And I found out that you don't want to do that. There are too many
> packages which are built against openldap, you'd end up rebuilding a
> rather large part of the distribution. 
there are a number of people that do exactly that and in fact, if you go
on the openldap-software list, they will tell you that if you expect
openldap to function, that you need to build it from source (either
2.3.37 (or whatever the latest is in 2.3) or 2.4.9 (or whatever the
latest is).

IIRC, you have to build from source...
- openssl
- kerberos
- cyrus-sasl
- db4
- openldap

I built everything in /usr/local and just left the distribution packages
intact and it worked.

I believe that Buchan Milne offers rpm packages that can install on
CentOS-4 and certainly Symas/Connexitor has rpm packages that you can
install but it wasn't that hard to build it from source.

That said, I don't recall syncrepl ever working in 2.2.x and have used
slurpd for replicating with 2.2 but if the OP says he thinks he had it
running, well, I'm not gonna argue with him.


More information about the CentOS mailing list