[CentOS] rebuilding kernel modules issues

Kenneth Burgener kenneth at mail1.ttak.org
Thu Jun 12 15:53:58 UTC 2008

I have a Tyan S3870 (K855A) motherboard which I would like to perform a 
burn in test with.  lm_sensors needs a kernel module compiled to be 
support this motherboard's sensors.

The instructions, for compiling the module, by tyan 
(ftp://ftp.tyan.com/software/lms/3870.sensors.conf) match closely with 
the instructions I found here 

I simply installed the kernel source (yum install kernel-devel) and 
tried the first basic step, cleaning (which is probably not needed at 
this point), but it threw the first of many errors I have run into.

# uname -a
Linux fwtest 2.6.18-53.1.21.el5 #1 SMP Tue May 20 09:34:18 EDT 2008 i686 
athlon i386 GNU/Linux

# cd /usr/src/kernels/2.6.18-53.1.21.el5-i686
# make clean && make mrproper
No such file or directory
make[3]: *** No rule to make target 
make[2]: *** [drivers/infiniband/hw/amso1100] Error 2
make[1]: *** [drivers/infiniband] Error 2
make: *** [_clean_drivers] Error 2

I then proceed to the next step of "make menuconfig".  I select the 
driver "i2c-piix4" and then save, exit, and attempt to compile the modules.

[root at fwtest 2.6.18-53.1.21.el5-i686]# make modules
   CHK     include/linux/version.h
   CHK     include/linux/utsrelease.h
make[1]: *** No rule to make target `arch/i386/kernel/msr.c', needed by 
`arch/i386/kernel/msr.o'.  Stop.
make: *** [arch/i386/kernel] Error 2

I tried deselecting the "i2c-piix4" driver, and tried again with the 
same results.  I also tried grabbing the .config file from /boot/ (cp 
/boot/config-`uname -r` ./.config) with the exact same results.

This is a clean, newly installed, fully updated system.  Shouldn't I be 
able to do this without error?  Am I missing another package to be able 
to compile the kernel modules as is?

Thanks for any help,

More information about the CentOS mailing list