[CentOS] FF3 printing problem on Centos 4.x

MHR mhullrich at gmail.com
Fri Jun 20 01:58:07 UTC 2008

On Thu, Jun 19, 2008 at 6:29 PM, fred smith
<fredex at fcshome.stoneham.ma.us> wrote:
> I'm using Centos 4.x (fully up to date) on a system at work. I have also
> been using firefox 2 (directly from mozilla.org) on it for a long time,
> and it tends to work just fine.
> yesterday I installed the new FF3 release. It works fine too, with one
> exception: The print dialog shows no printers! The print button is greyed
> out! There actually four or five printers defined on the system, and all
> other apps find them fine, including FF2.

I had that problem when I started using Seamonkey's 2.0 pre-release,
which incorporates a lot of the changes that went into FF3.  The new
mozilla software uses the CUPS print system, so if you're not using
that, or there are problems there, that's one place to look.   On
mine, it turned out that, for whatever reason (I never did find out
what), the cupsd daemon had died and never restarted.  I brought it
up, re-added the printer and now it works.

I did notice a couple of days ago that the print button failed on me
again, not just in seamonkey, but everywhere.  I tried restarting
cups, logging out and back in, and wound up rebooting.  I think this
time it had something to do with my printer being offline - the
parallel printers have a problem with reconnecting.



More information about the CentOS mailing list