[CentOS] 2.6.18-92.1.6.el5xen hangs Samba daemon

Brett Serkez bserkez at gmail.com
Fri Jun 27 11:48:27 UTC 2008


I have a fresh CentOS 5.2 server that I am just starting to customize,
it is very close to stock.

This morning I ran yum update:

 kernel-xen              i686       2.6.18-92.1.6.el5  updates            15 M
 samba                   i386       3.0.28-1.el5_2.1  updates            16 M
 samba-client            i386       3.0.28-1.el5_2.1  updates           4.9 M
 samba-common            i386       3.0.28-1.el5_2.1  updates           8.7 M

After rebooting, Samba would not start, running 'service smb start'
simply hangs forever, nothing in the logs I could find and I could see
from ps that smbd was never forking to release the start script.

I discovered that if I boot using the previous kernel
2.6.18-92.1.1.el5xen all is well.

I did try regressing samba by uninstalling and then installing
disabling the updates repo to no avail, the older version (1.1) of
Samba was installed when I tried booting the older kernel, which did
work, as well as the updated version (1.6).


More information about the CentOS mailing list