[CentOS] Clamd not working

AnneWilson cannewilson at googlemail.com
Sat Jun 28 09:05:52 UTC 2008

On Friday 27 June 2008 23:35:35 Paul Schoonderwoerd wrote:
> On Friday 27 June 2008 19:43:06 Anne Wilson wrote:
> > rm /var/clamav/* -rf
> > which will remove all the signatures. Don't worry, you'll get them
> > back in the next step. As root, type
> > freshclam -v
> > And that will download all the necessary signatures again.
> > </quote>
> >
> > At that point I thought all was well - until I had to reboot, when I
> > found that it hung with a message (from memory) 'self-checking 1800'. 
> > Using Interactive boot I discovered that it came from clamd.
> >
> > I'm guessing that daily.cld  main.cld  and mirrors.dat are being sought
> > somewhere other than /var/clamav.  Maybe a symlink is required?  If
> > someone with a working clamd could advise me I'd be most grateful.  For
> > now I have had to chkconfig clamd off.
> >
> > Anne
> Does the /var/clamav dir still exist ? It is in the clamd rpm.
> mirrors.dat, daily.cld and main.cld are in /var/clamav
> It seems easiest to me to reinstall clamd and clamav.
It does.  The original install was Dag's and worked without a problem.  Then 
came an update which broke ClamTK's operation.  With the help of the ClamTK 
dev that was fixed, but now I have this problem at bootup.  What I haven't 
tried, and will today, is booting with chkconfig off, but then starting clamd 
from the CLI.  If that is problem-free maybe I will need to talk to Dag.


More information about the CentOS mailing list