[CentOS] INIT 5 and system is gone

Robert Moskowitz rgm at htt-consult.com
Mon Jun 30 14:33:32 UTC 2008

I had been running a system on Centos 5.1 at INIT 3.  I did the upgrade 
to Centos 5.2 with the aid of the powernowk8 patch.

Previously I would VNC into the unit when I needed to do admin stuff 
with a GUI.  Well I noticed that I was NOT getting GNOME via VNC since 
the upgrade (worked before just fine with 5.1).  So I tried an INIT 5 
from the command line (always worked before), but the system seemed to 
hang.  Video was off.

I rebooted, went to INITTAB and changed init to 5 and rebooted.  
Probably a tragic mistake.

Now on boot, right after UDEV gets an OK, the screen goes blank and the 
drive stops turning.

I tried booting with the 5.1 kernel, and same behaviour with the system 
blanking out and all load activity stopping after UDEV loads.

So I am quite stuck at this point.

Is there an option that I can edit into the kernel command at boot time 
to init in 3?  And then what do I try?

If I have to reload Centos, I have to pull the drive, put it into 
another system, install there, etc.  Not my idea of a fun day....

More information about the CentOS mailing list