[CentOS] INIT 5 and system is gone

Michel van Deventer michel at van.deventer.cx
Mon Jun 30 14:50:12 UTC 2008


On Mon, 2008-06-30 at 10:33 -0400, Robert Moskowitz wrote:
> I had been running a system on Centos 5.1 at INIT 3.  I did the upgrade 
> to Centos 5.2 with the aid of the powernowk8 patch.
> Previously I would VNC into the unit when I needed to do admin stuff 
> with a GUI.  Well I noticed that I was NOT getting GNOME via VNC since 
> the upgrade (worked before just fine with 5.1).  So I tried an INIT 5 
> from the command line (always worked before), but the system seemed to 
> hang.  Video was off.
> I rebooted, went to INITTAB and changed init to 5 and rebooted.  
> Probably a tragic mistake.
> Now on boot, right after UDEV gets an OK, the screen goes blank and the 
> drive stops turning.
> I tried booting with the 5.1 kernel, and same behaviour with the system 
> blanking out and all load activity stopping after UDEV loads.
> So I am quite stuck at this point.
> Is there an option that I can edit into the kernel command at boot time 
> to init in 3?  And then what do I try?
Reboot your system, when you see the grub menu, press a key. Select the
kernel you wish to boot and press 'e', select the kernel line, press 'e'
again and add '3' at the end of the line (or '1' if you wish to boot in
single user mode). Then press <enter> and 'b' to boot. Your system
should now boot up in level 3. You can log in as root at the login
prompt. If that even doesn't work, the reboot in single user mode.

For the rest, we first need
logfiles, /var/log/messages /var/log/boot.log and
maybe /var/log/Xorg.0.log



More information about the CentOS mailing list