[CentOS] PE2950, RAID 0, failed disk

Thu Mar 6 18:53:15 UTC 2008
Scott R. Ehrlich <scott at MIT.EDU>

I have a Dell PowerEdge 2950 with PERC 5/i, and 6 disks.  Two disks have 
one logical volume via a hardware RAID 1 and consist of CentOS 5 64-bit; 
the remaining four comprise a logical volume via a hardware RAID 0, and 
is all user data.

One drive on the RAID 0 went bad.   I removed it while the system was on, 
tried a reboot, and the system hangs at RedHat Linux... Starting

I tried to boot from a Fedora 8 CD, which sees the boot drives fine, but 
not the RAID 0 partitions.

Visiting the PERC controller setup claims the RAID 0 volume is 
unavailable, or something similar, though it is defined, with one of the 
disks labelled as missing, since I removed it from the system.

How do I get the partitions on the RAID 0 setup back?   I have some of the 
data, but need the rest, if possible, and the remaining three disks appear 
physically healthy.   I'm also going to work with Dell for some answers, 
and I've done a lot of googling.