[CentOS] 5.1 did not detect marvell e-net controller

Fri Mar 28 20:43:05 UTC 2008
Clyde E. Kunkel <oldfart2231 at cox.net>

James Fidell wrote:
> Clyde E. Kunkel wrote:
>> James Fidell wrote:
>>> John wrote:
>> <snip>
>>> There's a more recent driver available than the one on the Asus site.
>>> Google found it for me.  Unfortunately I can't recall were I downloaded
>>> it from now.
>>> Unfortunately whilst it appears to work ok at 100Mb/s, I get a huge
>>> number of framing errors at 1000Mb/s.  I've not tried enabling jumbo
>>> frames yet though.
>> Th ASUS driver won't compile for me...just says compile error, look in 
>> the log.  The log says compile error.
> It wouldn't compile for me first time, either, because it wasn't looking
> in the right place for the kernel files.
> After installing kernel-devel and kernel-headers for the current kernel,
> I did something like:
>   # ln -s kernels/`uname -r`-`uname -p` /usr/src/linux
> and that fixed it for me.
> I was using the latest drivers I could find, from here:
>   http://www.marvell.com/drivers/driverDisplay.do?dId=153&pId=38
> James
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

I got past the missing kernel header files.  It said it was on the 
compile step when it failed, so I believe I got the symlinks right. 
Will try again (and again).  Thanks for the response.


Old Fart