[CentOS] DVD reader: Hardware problem or OS glitch?

Thu May 1 17:54:24 UTC 2008
William L. Maltby <CentOS4Bill at triad.rr.com>

On Thu, 2008-05-01 at 05:49 -0500, Lanny Marcus wrote:
> On 29 April 2008, "John" <jses2 ATgmail.com> wrote:
> <snip>

> I ran "yum update". The box is now 100% up to date. The problem did not go away.
> On CentOS 5, the Teac DV-516D  DVD/CD reader can mount a CD, without
> any problem. However, it sees a DVD as blank. On Windows XP, it works
> perfectly, with CD and DVD media.  I sent an email to Teac Tech
> Support, asking for the URL where I could download their Diagnostics
> for the drive and got this reply:
> >Unfortunately, no diagnostics are available as checking the read
> capabilities within >Windows XP is most than acceptable.   If the
> drive does not work properly within >Windows  or any other PC, then
> the drive needs to be repaired or replaced.

It's been a long thread, so I don't recall what all you've tried.

1st, /var/log/dmesg (also in messages)? Mine has

   Probing IDE interface ide0...
   ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
   hda: ATAPI 48X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache,
   UDMA(66) Uniform CD-ROM driver Revision: 3.20

After inserting media (video in this case), I get

   May  1 13:13:17 centos501 kernel: UDF-fs INFO UDF
     (2004/29/09) Mounting volume 'SHANGRILA', timestamp 2004/11/11
     05:24 (1f10)
   May  1 13:13:17 centos501 hald: mounted /dev/hda on behalf of uid 500
   May  1 13:14:59 centos501 hald: unmounted /dev/hda from
     '/media/SHANGRILA' on behalf of uid 500
   May  1 13:15:22 centos501 kernel: UDF-fs INFO UDF
     (2004/29/09) Mounting volume 'SHANGRILA', timestamp 2004/11/11
     05:24 (1f10)
   May  1 13:15:22 centos501 hald: mounted /dev/hda on behalf of uid 500

Any product literature? Is the drive ATAPI (MMC) compatible?
Have you checked on the web to see if there is a prom upgrade available?
A long time ago I found a site that has the upgrades for many drives.
BTW, a google search might get specs if you've no literature.

When you mount a CD, note device (sda, hda, ...) and then stick the DVD
media in. See if you can dd from it like so

    dd if=/dev/sdc of =/dev/null count=50

That might get you a clue as to if the CentOS at least handles the

Module                  Size  Used by
udf                    76997  1
autofs4                24517  2
hidp                   23105  2
dm_multipath           21577  0
sg                     36061  0 
ide_cd                 40033  1
cdrom                  36705  1 ide_cd
dm_snapshot            20709  0 
dm_zero                 6209  0 
dm_mirror              28741  0 
dm_mod                 58201  9
sata_via               15557  3 
libata                115833  1 sata_via
sd_mod                 24897  5  
scsi_mod              132685  3 sg,libata,sd_mod

Normally, the sg, scsi_mod, cdrom are used for MMC-complioant drives
(ATAPI) to utilize the SCSI command set across the ATA interface.

I think the ide_cd is just a left-over in my grub menu.lst that used to
be needed, but not sure.

> Disappointing and I will probably never purchase Teac components
> again. The box is dual boot (WinXP & CentOS 5). Years ago, I purchased
> SystemSuite 4. I installed that and ran their generic diagnostics on
> the Teac DVD/CD reader and it passed. I am not positive the Teac drive
> is working perfectly, but I have a high level of confidence in it.

I'm with you. Except for possibly having an old prom version in it
and/or needing some loadable modules for it in CentOS, it sounds like
the HW is good enough.

Have you done an lsmod when a CD is in? Then when a DVD media is in?

Here's mine with DVD in. Lot's of un-related stuff I'm sure - but I've
snipped out anything I'm sure is not related.

> My belief is that somewhere, there is either no support for the Teac
> DV-516D in CentOS 5, or, that something required to automount a DVD in
> it is not configured properly. It can mount a CD without any problem.

I vote for option two. Now, that *could* be due to the age of the drive
(i.e. the prom revision is missing something that has come to be
considered "universal" by the writers of the CD/DVD code portions).
However, it could also be that, like other manufacturers in the past,
there is some incompatibility in the drive. For more information, and a
serious test of your masochistic bias, install the cdr-tools package and
read the stuff under /usr/share/docs related to it.

> <snip sig stuff>