[CentOS] yum problem after last kernel (SOLVED)

Mon May 19 15:04:20 UTC 2008
Alex Palenschat <alex at nssmgmt.com>

>Hello all, I've been googling and haven't found an answer. I have a
>Centos 4.6 box that is having an issue since the last yum update. The
>nss_ldap and kernel packages were the only packages installed/updated.
>When I try to run yum I now receive:

>[root at ns1 ~]# yum update
>There was a problem importing one of the Python modules
>required to run yum. The error leading to this problem was:
>   /usr/lib/librpmdb-4.3.so: undefined symbol:
>Please install a package which provides this module, or
>verify that the module is installed correctly.
>It's possible that the above module doesn't match the
>current version of Python, which is:
>2.3.4 (#1, Dec 11 2007, 05:27:57)
>[GCC 3.4.6 20060404 (Red Hat 3.4.6-9)]

Responding to my own post. I'm not sure how it was corrupted, but I only
had to redownload the rpm-libs package and issue a rpm -Uvh --force
command to resolve this. So I thought I'd post it in case somebody else
runs into the same error.