[CentOS] RAID5 or RAID50 for database?

Sun May 25 10:26:42 UTC 2008
Christopher Chan <christopher at ias.com.hk>

Linux wrote:
> On Fri, May 23, 2008 at 4:19 AM, Christopher Chan
> <christopher at ias.com.hk> wrote:
>>> And stick with md-raid 10 (also known as software raid) because it is
>>> much more intelligently designed than any
>>> closed-source-embedded-raid-controller.
>> This was valid until...quite a few years ago.
> Has hardware-raid vendors open-sourced their firmware then?

So? Has the vendor of your motherboard open sourced their firmware? Do 
you flash a piece of open source bios code into your motherboard's chip 
if not so?

>>> Nowadays hardware raid frightens me because of the need to have spare
>>> raid-controllers for every hardware-raid-configuration I have. They
>>> are neither interchangable nor easily recoverable.
>> You seem to have been living under a rock for the last half decade.
> For each hardware-raid configuration I keep a redundant
> raid-controller. In case of controller failure it's the best way to
> recover my data on disks. I tried simple test cases once (yes, on the
> last half decade) and most failed except simple RAID-1 configurations.

Sorry, I have never had a 3ware card fail on me during my four years at 
Outblaze Ltd. and besides, other users of 3ware had just have to plug in 
another card and they got all their data back. Of course, I have heard 
of horror stories with other brands like Mylex which might act up on a 

>>> md-raid 10 can be established with any number of disks (at least 3 but
>>> better check with google)
>> Hmm, I think your advice must be taken with a grain of salt. Have you
>> actually tried to do what you suggest? In any case, I will give you the
>> benefit of the doubt that you just did a typo.
> mdadm raid10 is neither raid 1+0 nor raid 0+1. Go check with man mdadm
> or google. Each stripe is written on 2 different disks with a rolling
> frame and loss of 1 disk in 3 disk configuration can be recovered
> online.

OH, you were talking about that new module that is not available on 
Centos 4. That is the problem these days, acronyms are not necessarily 
uniform. Sorry, no experience with that particular module and I think 
this should clear up a lot of misunderstanding on answering questions 
about how do I make a "raid10" array during installation.