[CentOS] External ext3 USB Hard drive and selinux

Nifty Cluster Mitch niftycluster at niftyegg.com
Sat Nov 1 20:24:27 UTC 2008

On Wed, Oct 29, 2008 at 11:23:28AM -0400, Al Freundorfer wrote:
> I was directed to post this on the mailing list. See the following forum post 
> as a reference.
> http://www.centos.org/modules/newbb/viewtopic.php?topic_id=16710&forum=42
> I formatted my external ext3 372GB USB hard drive in ubuntu and now want to 
> use it 
> in Centos. I made sure that my group/user numbers were the same. I was not 
> able to write to the mounted USB hard drive (HD). I suspected selinux and 
> shut it of and I was able to copy the file! I set selinux back to enforce and 
> rebooted. I like the security features of selinux.
> I tried:
> 1) chcon -v
> 2) restorecon -Rv /media/disk
> 3) cp -P
> and still am not able to write to the USB HD. The sad part is I can delete 
> files from the USB HD. See forum post for details.
> I tried it in fedora 9 and it is able to write to the USB HD
> I tried an 32GB USB memory stick in Centos 5.2 and it worked!
> I am wondering why it doesn't work for my USB HD? The only difference is the 
> the size.

Try rebooting in permissive mode then inspect the avc messages.

Double check the permissions of the mount point before and 
after mounting the device.

	T o m  M i t c h e l l 
	Found me a new hat, now what?

More information about the CentOS mailing list