[CentOS] Problem with widescreen display

Marko Vojinovic vvmarko at panet.rs
Mon Nov 3 08:58:15 UTC 2008

On Sunday 02 November 2008 12:26, William L. Maltby wrote:
> On Sat, 2008-11-01 at 22:08 +0000, Marko Vojinovic wrote:
> > Basically, what I did was to run system-config-display to reconfigure for
> > the new monitor and resolution. All goes well, but after X restarts, I
> > see a strange picture: the resolution indeed goes to 1680x1050 as is
> > supposed to, but is squeezed/shrinked/scaled horizontally to match a 4:3
> > aspect ratio, leaving two (unequal) black bands on the left and right
> > side of the monitor.
> This sounds like the "Modes" line in the "Subsection Display" may not
> have the right settings. The manual/CD for the monitor should have the
> right settings. I would compare those against what the configuration
> process generated and manually edit if needed. Why the difference
> between FC4 and CentOS, I can't guess.

Comparing the CentOS and Fedora Xorg.0.log I found that the actual modelines 
are just slightly different. Assuming that this difference might actually be 
important, I took the known-to-work modeline from Fedora's Xorg.0.log, 
copy-paste it in CentOS xorg.conf and forcing X to use that. But the result 
is the same.

I will also try to find modeline data in the monitor manual, but I doubt that 
it is not going to be any different than DDC values that X autodetects.

> I don't have the URL, but some time ago I googled and found a very
> detailed description of the modes, their effects, "blanking" (the "black
> bands") and the relationship of all those. Go googling if you think if
> might help.

I'll look into that, to educate myself about modelines beyond the man page. 
But I have a feeling this problem is not related to modelines.

> > Btw, this is on an nVidia GeForce 4 using the default nv driver. The vesa
> > driver doesn't support widescreen resolutions, while nvidia binary driver
> > crashes X completely on start (but this is a known motherboard problem
> > common to FC4 as well).
> Have you tried the nvidia drivers from rpmforge? It has drivers for both
> the older and newer nVidia cards, all ready for CentOS. I'm using the
> older driver now (standard CRT though, not a newer LCD/TFT wide-aspect
> screen) and it works flawlessly.

Yes, I have tried the package from rpmforge, but it behaves the same way. But 
the problem with binary drivers is that my motherboard has a bug in the bios 
which autodetects and forces AGP to 8X, which in turn doesn't work for some 
reason. This is the same for both Fedora and CentOS, and I gave up on 3d 
acceleration on this hardware a long time ago. But this resolution problem is 
related to nv driver, present in CentOS while absent in Fedora. Therefore I 
believe it is unrelated to hardware issues.

Thanks for the help!

Best, :-)

More information about the CentOS mailing list