[CentOS] Re: Reinstalled Windows and GRUB - Cannot boot Linux - fstab and grub.conf errors?

Lanny Marcus lmmailinglists at gmail.com
Sat Nov 8 21:08:15 UTC 2008

There is a Permissions problem, when I try to access
/boot/grub/grub.conf and /etc/fstab so I can edit them. How can I do
that, using the Live CD's I have? I need root access.

On 11/8/08, Lanny Marcus <lmmailinglists at gmail.com> wrote:
> Background: This is a dual boot (Windows XP and CentOS 5.2 (32 bit)
> box. There were four (4) NTFS partitions. The C partition got full. I
> deleted the 4 NTFS partitions and did a clean install of Windows XP,
> into one (1) NTFS partition.
> I knew that I would need to install GRUB again and I did that, using
> the CentOS 5 Installation DVD. When I tried to boot into Linux, no
> joy. this is the GRUB error I got:
> Booting 'CentOS (2.6.18-92.1.17.el5)'
> root (hd0,2)
> Filesystem type unknown, partition type 0x8e
> Kernel /vmlinuz-2.6.18-92.1.17.el5 ro root=/dev/VolGroup00/LogVol00 rhgb
> quiet
> Error 17: Cannot mount selected  partition
> Press any key to continue
> (same error, trying to boot the 2 older Linux Kernels)
> The CentOS 5 Installation DVD apparently is now damaged (Murphy's
> Law). I have available to me:
> (a)  CentOS 5.2 i386 Live CD (I am running on that, as I write this email)
> (b)  Knoppix Live Disk, V.5.1.1
> (c)  SystemRescueCD V.0.2.15
> The partitions on my hard drive, as shown by QTParted on the Knoppix
> Live CD are now:
> 01   /dev/hda1  ntfs   Active
> 02   /dev/hda2 ext3              (/boot)
> 03   /dev/hda3 unknown      (CentOS LVM)
> My belief is that  /hda3 is not mounted. If I click on the "Local Hard
> Drives" Icon under "disc" it only shows hda2 (the Linux /boot
> partition).   How and where do I fix that?
> When I view /etc/fstab as centos user with the CentOS 5.2 Live CD, I
> see that the line I had to mount the NTFS data  partition (E: when I
> had 4 NTFS partitions) showed it as /dev/hda6
> Now, the only NTFS partition, C, is /dev/hda1.     Viewing it as
> centos user, in gedit, it is read only. When I try to view it as root,
> it shows me a /etc/fstab file that apparently is created by
> the LiveCD and doesn't show the Windows partition. How do I edit the
> /etc/fstab file so I can change it from /hda6 to /hda1? Here's the
> file contents:
> /dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
> LABEL=/boot             /boot                   ext3    defaults        1 2
> devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
> tmpfs                   /dev/shm                tmpfs   defaults        0 0
> proc                    /proc                   proc    defaults        0 0
> sysfs                   /sys                    sysfs   defaults        0 0
> /dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
> /dev/hda6       /mnt/win   ntfs-3g  rw,umask=0000,defaults 0 0
> TIA! Lanny

More information about the CentOS mailing list