[CentOS] Re: Reinstalled Windows and GRUB - Cannot boot Linux - fstab and grub.conf errors?

Lanny Marcus lmmailinglists at gmail.com
Mon Nov 10 16:07:00 UTC 2008

On Sun, Nov 9, 2008 at 4:22 AM, Vandaman <vandaman2002-sk at yahoo.co.uk> wrote:
>> There is a Permissions problem, when I try to access
>> /boot/grub/grub.conf and /etc/fstab so I can edit them. How
>> can I do
>> that, using the Live CD's I have? I need root access.
> Instead of using a LIVECD, have you tried using the CentOS
> rescue CD and then using the grub command. I don't have Centos 5
> but you can look at the CentOS docs or a quick Fedora example below.
> http://dailypackage.fedorabook.com/index.php?/archives/158-System-Recovery-Week-Rescue-Mode-and-Reinstalling-Grub.html

Initially, I was able to boot the CentOS 5 Installation DVD and that
is how I reinstalled GRUB, using "linux rescue", after the
reinstallation of MS Windows on this dual boot box. Somehow, the
CentOS 5 Installation DVD got damaged, as I tried to resolve this
problem, so now I am limited to the Live CDs I have and since I am
very limited in my knowledge of Linux, I don't know how to get real
root privileges,  while using the Live CDs.

Seems like I need to solve  two (2) problems, in order to get GRUB
working properly again on this dual boot box and be able to boot into
Linux again: (a) Get real root access, while using Live CD's (b)
Modify one or two configuration files (/etc/fstab and
/boot/grub/grub.conf) to reflect the fact that now there is only one
partition for Windows, where previously there were four Windows

Question: You mentioned the "CentOS rescue CD". Is there something
else, other than the CentOS 5 Installation DVD I have, which is
damaged? Our DSL is very slow (550) so it would take me a long time to
try to download that.

Note: Sorry for my delay in replying to you. Our ADSL went down
yesterday and the phone company just fixed their problem. TIA.

More information about the CentOS mailing list