[CentOS] Reinstalled Windows and GRUB - Cannot boot Linux - SOLVED

Lanny Marcus lmmailinglists at gmail.com
Tue Nov 11 01:03:28 UTC 2008

On Mon, Nov 10, 2008 at 4:32 PM, MHR <mhullrich at gmail.com> wrote:
> On Mon, Nov 10, 2008 at 12:58 PM, Lanny Marcus <lmmailinglists at gmail.com> wrote:
>> Question: Is /hda3 mounted properly? I don't think so, because when I
>> try to boot Linux from the Grub menu on the HD, it gives me "Error 17:
>> Cannot mount selected partition"

> Someone just answered earlier in this thread that you need to change
> your hd(0,2) to hd(0,1) on the grub boot line.  That should work.  You
> don't need to do this from any special rescue boot, just boot the
> system, and when the grub stage 2 boot selection shows with its
> countdown, stop it (with the space bar) and use the grub shell to edit
> that line and it _should_ boot properly.

Mark (MHR) and the earlier responder who previously mentioned to
change  to "root (hd0,1)" in the GRUB boot menu. A_SPECIAL_THANK_YOU!
That got me into CentOS5.2....  :-)  I did notice an error message,
when the box was booting, "mounting local filesystems failed" but I
think that has to do with mounting the NTFS partition, which I will
fix in /etc/fstab after I send this message.

> If WCTW, instead of downloading the CentOS 5 DVD, just pull down the
> first CD image and burn that.  It's a lot shorter than the whole DVD,
> and it's all you need to get into rescue mode.

OK. I will download the first CD, but not tonight, since my CentOS 5
Installation DVD is now toast. I ran into this problem, Saturday
afternoon, and the list is very slow on weekends and then our ADSL
went down, because there was a bad card in the phone company Router or
some other HW in our subdivision.  To everyone who replied, THANK YOU!

More information about the CentOS mailing list