[CentOS] SVN missing libexpat.so.0 while it is present

Berend Dekens berend at cyberwizzard.nl
Wed Nov 12 15:55:30 UTC 2008


Hopefully I am sending this to the correct mailing list but it seemed 
best suited for troubleshooting :-)

I am trying to fix Subversion which isn't working for me on one of our 
machines: every attempt to run 'svn ls' or 'svn co' ends in:
svnserve: error while loading shared libraries: libexpat.so.0: cannot 
open shared object file: No such file or directory

Which is strange as the symlink is present in /lib/libexpat.so.0 (which 
points to /lib/libexpat.so.0.5.0) and /usr/lib/libexpat.so.0 - I even 
tried copying an identical libexpat.so.0.5.0 from another machine. Next 
I ran 'ldd -r /usr/bin/svnserve':
ldd -r /usr/bin/svnserve
linux-gate.so.1 => (0x009df000)
libsvn_repos-1.so.0 => /usr/lib/libsvn_repos-1.so.0 (0x008a1000)
libsvn_fs-1.so.0 => /usr/lib/libsvn_fs-1.so.0 (0x00110000)
libsvn_fs_fs-1.so.0 => /usr/lib/libsvn_fs_fs-1.so.0 (0x0034f000)
libsvn_fs_base-1.so.0 => /usr/lib/libsvn_fs_base-1.so.0 (0x00c2d000)
libsvn_fs_util-1.so.0 => /usr/lib/libsvn_fs_util-1.so.0 (0x00857000)
libsvn_delta-1.so.0 => /usr/lib/libsvn_delta-1.so.0 (0x00f5f000)
libsvn_subr-1.so.0 => /usr/lib/libsvn_subr-1.so.0 (0x00ac1000)
libsvn_ra_svn-1.so.0 => /usr/lib/libsvn_ra_svn-1.so.0 (0x0094d000)
libz.so.1 => /usr/lib/libz.so.1 (0x00d8d000)
libaprutil-1.so.0 => /usr/lib/libaprutil-1.so.0 (0x0026c000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0x06dfd000)
libldap-2.3.so.0 => /usr/lib/libldap-2.3.so.0 (0x005f6000)
liblber-2.3.so.0 => /usr/lib/liblber-2.3.so.0 (0x007b5000)
libdb-4.3.so => /lib/libdb-4.3.so (0x07144000)
libexpat.so.0 => /lib/libexpat.so.0 (0x0086a000)
libapr-1.so.0 => /usr/lib/libapr-1.so.0 (0x00116000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00d74000)
libdl.so.2 => /lib/libdl.so.2 (0x00d45000)
libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0x06c45000)
libc.so.6 => /lib/libc.so.6 (0x0036d000)
libuuid.so.1 => /lib/libuuid.so.1 (0x00d64000)
libpq.so.4 => /usr/lib/libpq.so.4 (0x00167000)
libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0x0028b000)
libresolv.so.2 => /lib/libresolv.so.2 (0x0013e000)
libssl.so.6 => /lib/libssl.so.6 (0x00a78000)
libcrypto.so.6 => /lib/libcrypto.so.6 (0x004b0000)
/lib/ld-linux.so.2 (0x00bdd000)
libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x009e3000)
libnsl.so.1 => /lib/libnsl.so.1 (0x001bb000)
libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00771000)
libcom_err.so.2 => /lib/libcom_err.so.2 (0x00337000)
libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00187000)
libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x005eb000)
libkeyutils.so.1 => /lib/libkeyutils.so.1 (0x0033c000)
libselinux.so.1 => /lib/libselinux.so.1 (0x001d2000)
libsepol.so.1 => /lib/libsepol.so.1 (0x00dad000)

As you can see, all libs are found and present. I tried installing a 
custom Subversion 1.5.1 RPM which also fails the same way. Finally I 
installed all build tools and build the SRPM into a binary RPM and guess 
what? It also fails...

I tried rebooting the server, running 'yum update' a couple of times and 
right now I'm out of ideas....

I am running CentOS 5.2 - 32-bit in a virtual machine (don't think the 
latter matters but right now I don't know where to look for the cause).

Berend Dekens

More information about the CentOS mailing list