[CentOS] Virtual NICs (aliases like eth0:1) won't come up after reboot

Berend Dekens berend at cyberwizzard.nl
Thu Nov 13 10:49:25 UTC 2008

With one problem down I still have another remaining. Since the 
installation of our primairy webserver we have had a problem with the 
network aliasses.

Our server has 8 IP adresses so we used the tool provided in the GUI to 
specify (and name - for our own convinience) eth0 aliasses with the 
other 7 adresses. After setting them up, applying them, activating them 
and restarting 'networking' (I dare say this is a lot of button pushing 
just to enable one NIC) all is well and every program can use its 
preferred IP.

However, after a reboot, all aliasses are disabled: they are present in 
the configuration but they are not activated. I feared I did something 
wrong so I removed all addresses, tried to find more clues in the docs 
and now I'm back where I started.

How can I figure out what is wrong? I might add that I am not afraid of 
using a console (actually prefer it on linux servers) but I am new to 
CentOS so I tried to do everything by using the GUI - which in this case 
keeps failing...

Berend Dekens

More information about the CentOS mailing list