[CentOS] Virtual NICs (aliases like eth0:1) won't come up after reboot

Berend Dekens berend at cyberwizzard.nl
Thu Nov 13 20:51:49 UTC 2008

Kai Schaetzl schreef:
> or, at the same time while you are waiting for more replies, you could try 
> starting up with only the first alias and if that succeeds try the next 
> one and so on ...
I was doing exactly that. And I was trying to figure out how the 
networking scripts work and what they do - or don't in my case.

And after 3 hours I remember why I hate automated GUI's: its working...

I removed, renamed, manually modified and did all kinds of things to the 
network configuration using both the GUI and the console and after 
recreating (for the millionth time) the configuration for each 
interface... it worked. On one hand I'm glad it is working on the other 
hand I am dissatisfied because I have no clue what caused it and how I 
fixed it (usually I run into problems more than once so stuff like this 
is a bad omen).

On a side note, the network configuration tool keeps forgetting the 
alias number I gave to the NIC - each time I edit a configuration I need 
to set the alias number again as its back on 0.

Well at least I've got everything up and running again - thanks everyone 
for your help!


More information about the CentOS mailing list