[CentOS] Migration from VMWare to HP Blade

Matthew Walster matthew at walster.org
Wed Nov 19 12:59:56 UTC 2008

Hi all,
A few months ago, I migrated some of our internal servers to HP blades, as
the VMWare box they were previously running on was getting too slow.

However, it wasn't without it's problems, and eventually the only way I
could get them to work was:

Install the same version of CentOS on the blade (believed to be 5.0, but
/etc/redhat-release says 5.2)
Took down both servers, booting them off the SystemRescueCD, mounting all
the partition on /mnt/transfer etc
Ran rsync to copy all the data from one to the other - except /boot and
Brought the blade up, and saw that it booted fine.

However, a new kernel has been released and we tried rebooting... And it
panicked. It seems to be LVM related, in that it can't mount /dev/root - and
I've tried manually running mkinitrd to regenerate the initrd to no avail.

I was just wondering if anyone had encountered similar problems, and knew of
any solutions?

I'm from a debian background, so am a little unused to certain aspects -
when a yum upgrade installs a new kernel, where does it pull the information
for boot from? A configuration stanza from within grub's menu.lst?


Matthew Walster
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20081119/ff3ff757/attachment.html>

More information about the CentOS mailing list