[CentOS] noauto option ignored in CentOS 5.1?

nate centos at linuxpowered.net
Wed Nov 19 18:29:07 UTC 2008

I have worked quite a bit with CentOS 4.x with
SAN, multipathing, LVM etc. The way I mount my
file systems is using a script that is called during
startup that runs fsck, imports the physical volumes,
and volume groups, activates the logical volumes, creates
the mount point if needed then mounts the volume, I mainly
made it for software iSCSI due to the iscsi stack loading
after the system mount process. I adapted it to my fiber
channel systems as well and it worked great(mainly so
I could have a consistent experience between FC and

In testing with CentOS 5.1 it seems that my entries
in /etc/fstab that are marked "noauto" are still infact
queried when the system boots (before multipathing, etc
fires up). These devices don't exist at the time which
causes the boot to halt(so I can fsck the file system
manually). I have worked around it by commenting out the
line in fstab, and just adjusting my script to look for
the commented line, but this never happened under
CentOS 4.x, seems like a bug ? I peeked at Red Hat's
bugzilla but didn't see much.

If so I can file one..



More information about the CentOS mailing list