[CentOS] Migration from VMWare to HP Blade

Miskell, Craig Craig.Miskell at agresearch.co.nz
Wed Nov 19 19:12:23 UTC 2008

> Hi all,
> A few months ago, I migrated some of our internal servers to HP
> blades, as the VMWare box they were previously running on was getting
> too slow.
> However, it wasn't without it's problems, and eventually the only way I
> could get them to work was:
> Install the same version of CentOS on the blade (believed to be 5.0, but
> /etc/redhat-release says 5.2)
> Took down both servers, booting them off the SystemRescueCD,
> mounting all the partition on /mnt/transfer etc
> Ran rsync to copy all the data from one to the other - except /boot and
> /lib/modules
> Brought the blade up, and saw that it booted fine.
> However, a new kernel has been released and we tried rebooting... And
> it panicked. It seems to be LVM related, in that it can't mount /dev/root -
> and I've tried manually running mkinitrd to regenerate the initrd to no
> avail.
> I was just wondering if anyone had encountered similar problems, and
> knew of any solutions?
Having just done the opposite (test migrating a CentOS server from physical hardware to VMWare), I have a very good idea  :-)  It was CentOS 4, but the basic bits should be the same

You need to edit /etc/modprobe.conf, and change the line (or lines) that start with:
"alias scsi_hostadapter"

If the server was vmware, the existing lines are probably
alias scsi_hostadapter mptbase
alias scsi_hostadapter1 mptscsih

I'm not sure what you'll have to change mptbase and mptscsih to be; on HP servers, cciss is the correct driver.  Others will vary (you could try a quick basic manual install on the target hardware and see what gets put in that file by the OS installer).

After you've changed modprobe.conf, re-run mkinitrd and reboot.  Should be good to go.  You'll also have to watch out for HWADDR in /etc/sysconfig/network-scripts/ifcfg-eth*, either changing it to match your new hardware, or removing it entirely.  Kudzu will probably take care of sorting out the network card driver entries in modprobe; follow your nose and take a guess, you'll probably get it right.  Either way, mkinitrd is only necessary (in this case) to get access to your root device

Hope that helps,
Craig Miskell

Attention: The information contained in this message and/or attachments
from AgResearch Limited is intended only for the persons or entities
to which it is addressed and may contain confidential and/or privileged
material. Any review, retransmission, dissemination or other use of, or
taking of any action in reliance upon, this information by persons or
entities other than the intended recipients is prohibited by AgResearch
Limited. If you have received this message in error, please notify the
sender immediately.

More information about the CentOS mailing list