[CentOS] noauto option ignored in CentOS 5.1?

nate centos at linuxpowered.net
Wed Nov 19 19:34:10 UTC 2008

Matthew Kent wrote:
> On Wed, 2008-11-19 at 10:29 -0800, nate wrote:
>> I have worked quite a bit with CentOS 4.x with
>> SAN, multipathing, LVM etc. The way I mount my
>> file systems is using a script that is called during
>> startup that runs fsck, imports the physical volumes,
>> and volume groups, activates the logical volumes, creates
>> the mount point if needed then mounts the volume, I mainly
>> made it for software iSCSI due to the iscsi stack loading
>> after the system mount process. I adapted it to my fiber
>> channel systems as well and it worked great(mainly so
>> I could have a consistent experience between FC and
>> iSCSI).
> Hmm.. not sure about older versions of CentOS but for lvm over iscsi in
> 5.2 all you should need is
> /dev/foo.vg/foo.lv /foo xfs _netdev,noatime,rw 0 0
> in /etc/fstab and iscsi node startup set to automatic (which is the
> default I believe). _netdev being the key as it will mount it after
> iscsi is loaded and connected.

Found the root issue here I believe in /etc/rc.sysinit

if [ "${RHGB_STARTED}" != "0" -a -w /etc/rhgb/temp/rhgb-console ]; then
                fsck -T -t noopts=_netdev -A $fsckoptions >
                fsck -T -t noopts=_netdev -A $fsckoptions

It scans all file systems by default unless the _netdev option
is set, whereas in CentOS 4.x it ONLY scans the root file system

        if [ "${RHGB_STARTED}" != "0" -a -w /etc/rhgb/temp/rhgb-console ]; then
                fsck -T -a $rootdev $fsckoptions > /etc/rhgb/temp/rhgb-console
                initlog -c "fsck -T -a $rootdev $fsckoptions"

I'll think about filing a bug/feature request I think the 'noauto'
option should be included in the exclusion list.

Perhaps fsck should be fixed as well, according to the manpage
'noauto' means it won't get mounted when you do mount -a, perhaps
it should not get fsck'd either if you do fsck -A


More information about the CentOS mailing list