[CentOS] kbs-CentOS-Testing gnucash: status for CentOS 5?

William L. Maltby CentOS4Bill at triad.rr.com
Sat Nov 22 18:22:33 UTC 2008

I decided I would like to try GnuCash on my 5.x desktop system. I did an
available list and got this

   gnucash.i386        2.2.4-1.el5.kb         kbs-CentOS-Testi
   gnucash-docs.noarch 2.2.0-2.el5.kb         kbs-CentOS-Testi

Did a

   yum --enablerepo=kbs-CentOS-Testing install gnucash\*

That produced

   Package gnucash-docs-2.2.0-2.el5.kb.noarch.rpm is not signed

I figured I had forgot to install the gpg key, so I did that. Well, now
I have to instances of that key. When I try to remove one copy,

   # rpm -e gpg-pubkey-3e13cf5b-422eea1c
   error: "gpg-pubkey-3e13cf5b-422eea1c" specifies multiple packages

I tried removing the /var/lib/rpm/__* and rebuild, but no help. Still
have two instances of the key. Any way to clean that without a remove and
reinstall of all the keys?

Anyway, a search of the archives has an entry indicating that gnucash
was available for CentOS 4.x, but nada about 5. Am I too early on this?

Anyhoo, figuring that docs could be addressed later, I then foolishly
(need more coffee?) did

   yum --enablerepo=kbs-CentOS-Testing install --exclude=gnucash-docs \

which, of course produced

   Error: Missing Dependency: gnucash-docs >= 2.2.0 is needed by package
   gnucash-2.2.4-1.el5.kb.i386 (kbs-CentOS-Testing)

Undaunted, I figured to download via yum and force installation with
nodeps (hmm, yum --downloadonly didn't work. Nothing in the docs about
that though. Did 

   yumdownloader --enablerepo=kbs-CentOS-Testing gnucash-docs

and that worked)


   rpm --install --nodeps gnucash-docs-2.2.0-2.el5.kb.noarch.rpm 

worked, but gave

   I/O error : Attempt to load network entity
   I/O error : Attempt to load network entity
   I/O error : Attempt to load network entity

The docs were installed though AFAICT. ISTR seeing stuff similar to this
with other packages in the dim past. Don't recall any solutions though.

I wonder if there's a way to suppress that activity. I don't
particularly care for packages that require on-line references for local
and potentially sensitive work. I'm thinking there might be a
configuration file I could modify because I see some similar files
already on the system. I'll pursue that later if I get gnucash

Back to the primary task, did

   yum --enablerepo=kbs-CentOS-Testing install gnucash

That produced

   Package gwenhywfar-2.6.2-2.el5.kb.i386.rpm is not signed

At that point I felt maybe I was a bit premature as I had already
confirmed that I had the gpg key installed.

Any words of wisdom for me? If I don't need to worry about the signing
issues, I guess I could download and install all with --nodeps. Good/bad
idea? Anything I might do to help the process along? I've not done any
rpm work, so it might take awhile if there is anything too technical.

I'm going to fire up my 4.x and see if it works there. I can muddle
through there, with a small amount of inconvenience. But that might be
worth it.

Before I forget, thanks to you and all the crew for the hard work that
benefits us all.


More information about the CentOS mailing list