[CentOS] Correctly setting up sound with Intel High Definition ICH7

Niki Kovacs contact at kikinovak.net
Sun Nov 23 20:51:11 UTC 2008


Earlier this day I started a thread about Skype not working with 
outgoing sound. Now I wonder if it's not a problem with my soundcard. I 
had a vague suspicion about this, but since it's way off the original 
topic, I decided to start a new thread about this.

Here's what the soundcard looks like:

[root at grossebertha etc]# lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High 
Definition Audio Controller (rev 01)

Actually plain sound (output) works OK. I can use XMMS, MPlayer, VLC and 
the likes without any problem.

On the other hand, when I try to record sound over the soundcard, the 
result is quite fuzzy, full of distortions. I tried to fiddle with 
alsamixer to get rid of the distortions, but to no avail. Here's what I 
did to record sound over the mic:

$ arecord > ~/test.wav

Now in the past I configured a laptop with an ICH sound card on it, a 
small ASUS. I spent like whole afternoons googling and searching through 
forums, until some day I stumbled over the solution. I had to add 
something to /etc/modprobe.conf, something like:

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=3stack

... and all of a sudden sound worked.

Now maybe there is also a magic line for my new machine (a lenovo 
desktop PC) that makes the soundcard work correctly for the microphone? 
But where do I get that information? Guesswork? Google again for a week? 
Searching for "centos intel high definition sound" doesn't show much.



More information about the CentOS mailing list