[CentOS] PPTP VPN server

"Germán Andrés Pulido F." gpulido at gtscolombia.com
Mon Nov 24 16:23:34 UTC 2008


I've been using linux to give VPN access to my corporate LAN using the 
following software:

Centos 5.2 x86
kernel 2.6.18-92.1.18.el5xen
pptpd (poptop) 1.3.4
ppp 2.4.4

The Centos server has directly connected the Internet Router, on one 
interface (eth1) and the LAN on another (eth0) and it works as the 
firewall/VPN server of my LAN.
It mostly works, however, if I try to connect using remote desktop 
(terminal services) to our windows domain controller (for example, it 
will happen with any windows server) the Centos server will just reboot. 
I can connect to the windows, authenticate, and work for about 5-10 
seconds before the linux reboots. It's not a friendly reboot, it just 
crashes and restarts. This linux is running virtualized with xenserver 
express, and the windows domain controller is running as another virtual 
machine in the same physical computer. I've updated the CentOS server, 
using yum update but it will still crash. I tried installing pptpd from 
source, but still crashes the same way. I googled a bit, and somebody 
said it had a similar issue but solved it lowering the MTU in the WAN 
interface of the VPN server. I did it, but nothing helped. I've searched 
bug reports on this, but there seems to be none. Any idea what can I do 
to fix this? or does anybody know another good VPN server for linux? (I 
know about openvpn and using ipsec+xl2tpd but these require additional 
software on the client or are not very linux-friendly). My main 
requiements for the VPN server are:

- it should require no additional software on the windows clients (Vista 
and XP currently)
- it should work fine with Mac OS X and linux clients
- if posible, not very hard to setup ;)

Thanks a lot, and sorry for the long post.



 Ingeniero de Proyectos
 Tel: (571) 658 34 10 ext 110
 Carrera 7b No. 123-46
 Sitio Web: www.gtscolombia.com

More information about the CentOS mailing list