[CentOS] Yum weirdness

Sorin Srbu sorin.srbu at orgfarm.uu.se
Thu Nov 27 13:37:16 UTC 2008

Hi all,

Running CentOS 5.2 x86.

Tried to do a yum update on the command line a while ago and an error stating 
"No module named yum" popped up.

I then tried importing the yum module by first entering "python" in a terminal 
window and then "import yum", for which I was rewarded with a "ImportError: No 
module named yum".

Then I downloaded a yum rpm-package via pbone.net. I got this one 
and then did an rpm -Uvh on the rpm-file, then tried running yum again with no 
success. I still got the no module named yum-message.

I further did a rpm -q yum* and was told that the above rpm wasn't installed, so 
I redid the install but added --force, but yum still gives the error message.

Running rpm -V yum* rpm* python* gives

package yum-3.2.8-9.el5.centos.2.1.noarch.rpm is not installed
package rpm* is not installed
package python* is not installed

Which is kinda weird, unless I'm missing something really obvious...

On a hunch I ran yum extender from the startmenu, or whatever it's called in 
CentOS, and this works. It says yum v3.2.8 IIRC is invoked. I got a list of 
updated packages, the ones Karanbir announced recently and they installed fine 
w/o any problem.
	Yum has run fine when I used it about three-four weeks ago. Same problem is 
seen on three of my workstations. The fourth, a server running the latest 
x86-PAE kernel runs yum just fine on the command line.

The answers I find searching the web more or less replicates the above steps 
I've already done, so I'm kind off at a loss here on what to do next to have yum 
on the command-line working. Can you guys help?

# Sorin Srbu				[Sysadmin]
# Dept of Medicinal Chemistry,	Phone: +46 (0)18-4714482 >3 signals> GSM
# Div of Org Pharm Chem,		Mobile: +46 (0)701-718023
# Box 574, Uppsala University,	Fax: +46 (0)18-4714482
# SE-751 23 Uppsala, Sweden	Visit: BMC, Husargatan 3, D5:512b
#					Web: http://www.orgfarm.uu.se
# ()  ASCII ribbon campaign - Against html E-mail
# /\
# MotD follows:
# If brute force doesn't solve your problems, then you aren't using enough.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 5126 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20081127/982809af/attachment.bin>

More information about the CentOS mailing list